Jump to content

Logitech Issues / joystick related


Ira Robinson
 Share

Recommended Posts

I am looking for ideas to help me troubleshoot the fact that my joy stick all of a sudden doesn't want to control the aircraft.  Something as simple as twisting the stick to stear on the ground, or pull straight back to take off;  nothing works.   I am using the Logitech.Extreme 3D Pro and this is across the board.  The problem exists in both  P3D version 4 and 5 and also in MS2020.   There is no calibration set up I think I haven't tried, so any suggestions will be appreciated.

 

__________

Ira Robinson

Link to comment
Share on other sites

Ira,

I have experienced a similar issue.  It happens after I have been using MSFS, and then load up FSX.  In FSX, my yoke and pedals do not work at all.  The controllers appear in the configuration app within Windows, but if I try to check them or calibrate, I get an error that they are not working correctly.  Only by completely restarting the PC can I get the controls working again in FSX.    I do not recall this problem when I first installed MSFS, so I am wondering if it's something that's happened after one of the sim updates.    

Drew

Edited by Andrew McCabe
typo

944416

Link to comment
Share on other sites

They all seem to be.  Swapping plugs around the rest still work fine.   One thing I did finally try today was to open up an old PC and try that.  The joy stick worked in P3D all of a sudden in both PC's.  But it didn't work at all in MS2020 in either PC.   So it isn't the ports and it may be the software but I haven't yet figured out where the configuration settings are - at least ones that work.

Even odder?  Button commands on the joy stick do work on both machines.   So I think I have it narrowed down to the x and y axis commands but I still have nothing concrete to base that opinion on

__________

Ira Robinson

Link to comment
Share on other sites

Hi Rob.  I have no idea anymore.  plus  or  minus, x  pr z,   it is all running together now.  Yopu would think there would be a config file somewhere that we could use, but anything I try either doesn't do anything or does something funkly.  I just haven't been able to isolate anything and maybe that's the problem.  I can't find a place to actually begin programing

__________

Ira Robinson

Link to comment
Share on other sites

  • 9 months later...

FSUIPC allows you to assign sources to controls, so for example, the elevator axis on your joystick can be identified and tied to the elevator in your sim.

Alistair Thomson

===

Definition: a gentleman is a flying instructor in a Piper Cherokee who can change tanks without getting his face slapped.

Link to comment
Share on other sites

  • 2 weeks later...

Well that didn't work.  Or at least it didn't solve the problem because I couldn't figure out how to make that work.  I just didn't understand how to use it.  

This is nuts.  Whatever happened to plug and ,play?

__________

Ira Robinson

Link to comment
Share on other sites

On 3/8/2022 at 7:01 PM, Robert Shearman Jr said:

Have you perhaps set the control to "Axis X+" instead of "Axis X"?  It's an easy miss, but, it does in fact mean something different.   I found out the hard way myself.

Hey Rob, I don't msuppose you have  config file more something I can copy over?

__________

Ira Robinson

Link to comment
Share on other sites

On 1/12/2023 at 2:43 PM, Ira Robinson said:

Hey Rob, I don't msuppose you have  config file more something I can copy over?

This is a Windows issue, I think. I had this issues in FSX, MSFS and P3D, all with windows 10+. I even went into the reg to tell the machine not to isolate USB ports, there is/was a fix for this which was an app you can download which effectively does the previous. It took my a good year on and off to find it but the issue still randomly crops up to the point where I can rarely be bothered setting up a flight.

 

https://www.avsim.com/forums/topic/487313-spad-or-saitek-plugins/page/2/#entry3409396

http://forums.pilotedge.net/viewtopic.php?f=14&t=5608

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

well, no luck whatsoever.  nothing  have tried has worked.   The only thing I haven't done is a complete line by line reconmfiguration of the set up.  There doesn't seem to be a point considering I can't even get the basic throttle or up and down movements to work!

All of the different options and  movement seem to allude me and when I try to use an outside program to help I only make it worse.  I justy don't get it.   So I am open to any suggestions at all. 

__________

Ira Robinson

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...