Jump to content

vPilot Hangs When Trying To Set PTT


Recommended Posts

Hi there,

I have vPilot v. 3.4.0 and no matter what I do, I cannot set a PTT button because the application hangs as soon as I select the 'Set new PTT Key or Button' option. I have tried unplugging all USB devices (except for my keyboard and mouse), I have restarted the computer multiple times, I have run the program as administrator and not as administrator, and I have reinstalled it twice. I can change ALL other settings, but as soon as I click the button to set a PTT key, the program hangs.

I am wondering if anyone else is experiencing this and if there is a workaround?

Link to comment
Share on other sites

22 minutes ago, Ross Carlson said:

Do you have any joystick/yoke driver applications installed that may be blocking vPilot from accessing USB devices?

No. Nothing installed. I am using the TCA Sidestick and to my knowledge, it is using the generic drivers as I have never installed software for them. Even when they aren’t plugged in, I can’t even set a key via the keyboard (i.e. spacebar).

If I let the program sit long enough it begins responding again, but without registering the key. If I try to set the PTT again, it hangs again (usually three to four minutes).

Link to comment
Share on other sites

1 minute ago, Ross Carlson said:

If you can do it without causing a large hassle for yourself, I would try deleting the usb devices from your machine (not just unplugging them) one by one to see if one of them is causing the issue.

Hi Ross,

I have been doing some digging and reading old posts, and I came across a program (JoystickScan.exe) that you had posted in another thread and I ran it on my computer. It came back with nothing. And I have no devices plugged into the machine (other than my keyboard and mouse).

If this test shows nothing, should I still uninstall my USB devices? I am at a loss for what to do next.

I appreciate the help.

Link to comment
Share on other sites

I wanted to follow-up with this thread. After a few days of messing around, it looks like my Reverb G2 headset was somehow preventing vPilot from registering the PTT key. I can confirm that the controllers were off, however the headset was active (but not detected via the JoystickScan.exe software). I determined this by removing all USB devices, and rebooting the system with the VR headset off. When I did that, I was able to set the PTT key.

Thanks again for the help and suggestions.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Hi all,

Just to add to this im also seeing this issue with a new install of windows 11 (all windows updates done) and a fresh install of VPilot

I'll have a mess with the usb's and see. Jonathan can i assume once it was set it all worked ok after?

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...