Jump to content

MSFS intermittent freezing with vPilot [SOLVED]


David Clark
 Share

Recommended Posts

** Eventually traced to USB headset fault, the headset seemed to be doing something to jam or modify inputs from other devices. Detected because I noticed that when trying to select my usual PTT key in the settings, it would take a long pause and most of the time detect the incorrect button or key (eg. pressing left CTRL key showed up as Joystick button or another key). I never thought to remove the headset when trouble shooting as I assumed any device issue would be the joystick or throttle. **

 

Hi I wonder if Ross or anyone could help me, I am all out of ideas on this!

When I start vPilot (latest version, but was same in previous version) it intermittently causes freezes in MSFS which can come back in a few seconds or a few minutes. No CTD. Closing vPilot unfreezes. I can't think of any change I made to my setup on the day it started (mid October), except unusually I had vPilot and Volanta running before I launched MSFS (normally I start them after). MSFS froze during the launch that day (not even connected to VATSIM) and I noticed it unfroze if I closed vPilot.

Then I re-opened it once spawned in and connected to the network and instantly got a long freeze.

Over the last 3 weeks I have managed to get it almost useable by removing default models and AIG models and only having FSLTL models and model matching vmr file - I managed one full flight in the LSGG-LICR event with no freezing. Then last night I managed a full flight EKCH-EHAM and it only started freezing during taxi to gate.

But today I am doing some testing and it's worse than ever, with a 'clean' launch and no Community add-ons it's freezing every few seconds for 10 secs to 1 min+ and it starts just by launching vPilot (I don't even have to connect to the network).

 

I have tried:

-  uninstalling vPilot and re-installing

-  installing latest version

- installing latest FSUIPC7

- removing the default models from vPilot options

- checked vPilot and MSFS running ADMIN

- removing OneDrive completely per the solution another user had for same problem (and re-installing vPilot), even though it worked fine before October with OneDrive installed

- Clearing whole Community folder including all AI models

- Closing down FSUIPC7

- Checking anti-virus is excluding vPilot and MSFS folders

- verfiying MSFS files via Steam app

 

I am out of ideas - is there any way to see a log of what is happening in MSFS during the freezes to pinpoint how vPilot is interacting with/commanding the sim? The vPilot log file doesn't seem to say much (example below, during severe freezing).

Thanks for any ideas!

Dave

 

 

2022-11-08 13:24:45.655 +00:00 [INF] vPilot version 3.4.7 starting up
2022-11-08 13:24:45.672 +00:00 [INF] Running in "Standalone" mode
2022-11-08 13:24:46.983 +00:00 [INF] Downloaded 7 servers
2022-11-08 13:24:47.420 +00:00 [INF] Validating "Msfs"
2022-11-08 13:24:48.069 +00:00 [INF] "FbwVpilotActive" value changed: false
2022-11-08 13:28:28.319 +00:00 [INF] vPilot version 3.4.7 starting up
2022-11-08 13:28:28.339 +00:00 [INF] Running in "Standalone" mode
2022-11-08 13:28:29.638 +00:00 [INF] Downloaded 7 servers
2022-11-08 13:28:30.419 +00:00 [INF] Validating "Msfs"
2022-11-08 13:28:31.082 +00:00 [INF] "FbwVpilotActive" value changed: false
2022-11-08 13:45:30.574 +00:00 [INF] vPilot version 3.4.7 starting up
2022-11-08 13:45:30.592 +00:00 [INF] Running in "Standalone" mode
2022-11-08 13:45:31.860 +00:00 [INF] Downloaded 7 servers
2022-11-08 13:45:32.285 +00:00 [INF] Validating "Msfs"
2022-11-08 13:45:32.891 +00:00 [INF] Aircraft config paths hash is different
2022-11-08 13:45:33.403 +00:00 [INF] "FbwVpilotActive" value changed: false

Edited by David Clark
Link to comment
Share on other sites

  • David Clark changed the title to MSFS intermittent freezing with vPilot [SOLVED]

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...