Jump to content

Vatspy problem -- error loading config


Recommended Posts

Just in the last couple of days, when I try to launch Vatspy I get an error message: Error Loading Config - There is an errror in XML doc (0,0)

 

I have tried reinstalling Vatspy but it makes no difference. My Servinfo still works fine fortunately.

 

Anyone know how to fix this?

 

Thanks

 

Clive

Link to post
Share on other sites

Somehow your config file got corrupted. To fix, enter this into a windows explorer address bar:

 

%appdata%\VAT-Spy

 

Press enter, and it'll open the vatspy config folder. Then delete the file called VATSpyConfig.xml (you might not see the .xml extension)

 

Then restart VAT-Spy.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
  • 1 year later...
  • 1 month later...

a 6 year bump? you should really see a doctor

 

hey its only a 1.5 year bump

 

maybe a sticky here

 

I had this problem awhile ago

 

 

Ross any idea on what is causing the file to become corrupted?

ZAU S-2, Major Certified

ZAU S-1 Mentor

(Disclaimer: the post above does not necessarily express the opinion or stance of ZAU or ZAUs training program, this view is made by me and me alone)

7664.png

Link to post
Share on other sites
  • 3 years later...
  • 8 months later...
  • 5 years later...
  • 2 months later...
  • 2 months later...
  • Board of Governors

I would suggest you have another issue, then.... Not sure what, though. Without knowing the correct statistic, I would imagine that 99.99%+ of people do not need to do that every time. I'm not a software guy, though, so don't really know.

Don Desfosse
Vice President, Membership

Link to post
Share on other sites
I have to do this *every time* I start VATSpy. It's unfuriating!

 

Very strange ... something is causing the file to get corrupted every time you run the program. The config file gets written when VAT-Spy shuts down, so that your settings (including the size and position of the window, etc.) are saved for the next time you run it. Are you shutting down VAT-Spy normally with the X in the top right corner, or are you pressing alt-F4 to shut it down, or are you using the "Exit VAT-Spy" option from the right click menu on the tray icon?

 

Or, are you leaving it running and it gets shut down when you shut your computer down?

 

Your answers to the above questions might help determine if it's a bug in VAT-Spy versus something else like an anti-virus application that is causing the file save to fail.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Hi Guys,

Im new to VATSIM, so am unsure where to put thus or if im putting it in the correct sun category, This morning I downloaded Vatspy with no problem and opened it up and saw it working fine, however after closing it, ive been unable to open the application again, it just doesn't work? uninstalled and re installed 5/6 times now and also removed the VATSpyConfig.xml file that others have suggested. Really hope you guys can help me.

Thanks,

Jonny

Link to post
Share on other sites
  • 11 months later...
On 1/31/2020 at 5:27 PM, Ross Carlson said:

 

Very strange ... something is causing the file to get corrupted every time you run the program. The config file gets written when VAT-Spy shuts down, so that your settings (including the size and position of the window, etc.) are saved for the next time you run it. Are you shutting down VAT-Spy normally with the X in the top right corner, or are you pressing alt-F4 to shut it down, or are you using the "Exit VAT-Spy" option from the right click menu on the tray icon?

 

Or, are you leaving it running and it gets shut down when you shut your computer down?

 

Your answers to the above questions might help determine if it's a bug in VAT-Spy versus something else like an anti-virus application that is causing the file save to fail.

Hi,

i've further informations for you.

I'm able to "broke" Vatspy simply closing it from the 2nd monitor; starting again the application will show a white window instead the world map.

If i try to cancel the config file, everything working fine until i close the window from the 2nd monitor, otherwise i can close and reopen it without issue if i stay on the default monitor.

 

Davide

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...