Jump to content

vSTARS 1.1 open beta


Recommended Posts

Not that I know of ... if it were my machine, I'd run a packet sniffer and see if I can figure out why the download is failing.

 

If you wait until after the server list download error appears BEFORE opening the settings, does it work? It should show you the last-saved server list, one of which is included in the default empty config file.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Yup, somehow your cached server list got wiped out. I've looked through the code and I don't see how that could happen.

 

In your config file, replace with this:

  <CachedServers>
   <string>4k1TtUZ1nMPNLZ+wSpkWmh+XJ59IS8vu</string>
   <string>cLr0UMkbKn0RaJtf4vbnSEezPrpv2jM3</string>
   <string>u65ZS/Db6ogfeAJf3VFD5AqplOiZL8Yc</string>
   <string>nFMkI7Z/mS2LrNEoqFqyburALllzrYN2</string>
   <string>Ij0W+XaSQ5H9VRX3u5NM40Fd3OA6KgdW</string>
   <string>UGVYQmHNW7tRUr5TOuo0LvpEILpnjd1TQV3c4DoqB1Y=</string>
   <string>VyZd/HPj+UoBGBdwLLFTaPW6xQAyf3uK</string>
   <string>yypsknI4KOTZnVFwvcELJIAhROfFU/nI</string>
   <string>Q99hP/C9u0VR2pRbNTcDxqvo6ZXMuizo</string>
   <string>gdXXJARo4KuT0P/Mwm9OebI6vX3jZLpj</string>
   <string>DUW+7vfFVZYEYjvWSgGuBQTorBTrarAr</string>
   <string>IaAPNojEBRqyxhdwujS9JkFd3OA6KgdW</string>
   <string>0iial2q8AXrEt6yVYzjP5Ef/C+UlFC1a</string>
   <string>fvwcVNu5aTmeNNIVPIPtTVQ0gSUhHKzy</string>
   <string>mQkHhEUclR+hhgpbr9/RU5ImYQ1n8cvN</string>
   <string>hCNziza/NPW576xAv5UKIZ6CLNprOcya3hmgV5zn3KE=</string>
 </CachedServers>

 

I would like to understand how the cached servers list got wiped out, so if this problem recurs, please let me know ... we might be able to get it fixed if we are able to reproduce it.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Just a quick feature request. I am finding myself using vSTARS in the TWR/GND/DEL positions on the network. The one thing is that I need to manually CTRL + F to set the vis range for those positions. Then when I get a updated file from my FE, those settings wipe. Is it possible this can be stored in the Settings dialog?

Link to post
Share on other sites
Just a quick feature request. I am finding myself using vSTARS in the TWR/GND/DEL positions on the network. The one thing is that I need to manually CTRL + F to set the vis range for those positions. Then when I get a updated file from my FE, those settings wipe. Is it possible this can be stored in the Settings dialog?

These settings will wipe because they are part of the facility file. You'll just have to change it every time you update your file (which hopefully isn't terribly frequently).

Link to post
Share on other sites
  • 3 months later...

Version 1.1.6 is now available, this fixes the following items:

 

- 0002642: Need to ignore unreadable devices when scanning for PTT.

- 0002552: Crash in settings window when servers aren't downloaded.

 

Download here:

 

http://vstars.metacraft.com/[Mod - Happy Thoughts]ets/Files/Installers/vSTARS-Setup-1.1.6.exe

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
  • 2 weeks later...
- 0002552: Crash in settings window when servers aren't downloaded.

User in my facility still experiencing this when migrating from v1.0 to 1.1.6. Had to paste in ServerURL and CachedServers values from my XML to his to stop the Unhandled Exception from occuring when opening settings window.

Dhruv Kalra

VATUSA ZMP ATM | Instructor | VATSIM Network Supervisor

878508.png878508.png

Link to post
Share on other sites

Version 1.1.7 is now available, this fixes the following item:

 

- 0002646: Nested alias functions don't p[Mod - Happy Thoughts] correctly.

 

Download here:

 

http://vstars.metacraft.com/[Mod - Happy Thoughts]ets/Files/Installers/vSTARS-Setup-1.1.7.exe

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
  • 3 months later...

Hi there...

 

Been using STARs to work a Tower position, and though it's not built for it, it works pretty well. The only issue I'm seeing is the flight strips. It might be an issue I've created on my own, due to lack of knowledge, but I've been unable to use strips that aren't pushed from another controller. When pushed from another controller, either below, or above, they put themselves nicely in the bay.

 

However, when working top down, flight strips need to be automatically generated. This is supposedly possible using the separators, and defining parameters for each... I've configured them properly, I believe but have not been receiving auto-generated strips.

 

For example, the Departures separator has the departure field properly set up but never brings in new departures. Similarly, arrivals do not appear under the Arrivals separator, which is also properly configured.

 

User error, or is this broken somehow?

Brin Brody (1354520)

Air Traffic Manager - Virtual Jacksonville ARTCC

Regional Advisor, Americas - VATSIM Special Operations

Link to post
Share on other sites
Hi there...

 

Been using STARs to work a Tower position, and though it's not built for it, it works pretty well.

 

Oh it's built for it alright.

 

Looks like it! Appeared to be very TRACON based (as expected) after a first look. Didn’t expect nearly as much TWR support.

 

Thanks.

Brin Brody (1354520)

Air Traffic Manager - Virtual Jacksonville ARTCC

Regional Advisor, Americas - VATSIM Special Operations

Link to post
Share on other sites
  • 2 weeks later...
  • 8 months later...

vSTARS version 1.1.7 has been in open beta for over a year now, so I think it's time to call it stable. 1.1.7 is now the official stable version available via the Download page on the vSTARS web site.

 

Thank you to everyone that helped test the open beta version!

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Enrico, if you're referring to the error that occurs if you reconnect to a voice channel (like if you disconnect then reconnect) then that is on the bug list and will be investigated the next time I work on the code. If you're referring to something else, please post a new thread with all the details.

 

Thanks.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
Enrico, if you're referring to the error that occurs if you reconnect to a voice channel (like if you disconnect then reconnect) then that is on the bug list and will be investigated the next time I work on the code. If you're referring to something else, please post a new thread with all the details.

 

Thanks.

 

Yes, I was referring to that.

 

Thanks

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...