Jump to content

Vpilot port issue


kyle wilford 943459
 Share

Recommended Posts

Hey guys, I've had this over at vatpac and now been advised to post on here! I know that there is some older post that go back on this but I can not find them to save my life right now! :/

 

Anyway issue is act show up in vpilot connect fonecto them and then 2 min later unless I re push the talk button they and I can not contact me. I've set up port forwarding along with a static address and still having the same issues and I'm getting frustrted as hell and I do not know what to do.

 

Hopefully someone can help.

Kyle Wilford

VATPAC Member

Link to comment
Share on other sites

Are you sure that the IP address of the computer you want is 10.0.0.36 as you've shown in the picture? If you're using Windows, open Command Prompt and then type "ipconfig". The IPv4 address is the one you want to set the port to forward to. Here in North America, all of the addresses I've ever seen are always 192.168.X.X, but that could be different where you are (I'm no internet/networking expert).

spacer.png

Evan Reiter
Boston Virtual ARTCC/ZBW Community Manager

 

Link to comment
Share on other sites

10.*.*.* is another internal block similar to 192.168.*.*, so that should be fine. It looks like that's correct given the screenshot he posted of his IP settings, although the screenshot is very small and hard to read, at least for me.

 

Kyle, can you please post an updated screenshot of your port forwarding settings?

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

And just to reconfirm, the issue is that if you have a period of time where you don't transmit on frequency, you'll eventually stop receiving voice? And once you activate your PTT key to transmit, you'll resume receiving transmissions as before?

 

Two possibilities I can think of would be: 1) Your router isn't applying the port forwarding settings (perhaps it needs a reboot?), or 2) vPilot isn't using UDP port 3290 to receive voice.

 

#2 is certainly possible if for some reason it thinks that port is in use or otherwise unavailable, in which case it'll allow a random, high-numbered port to be used instead. The web interface for a voice server you're connected to would be able to confirm whether this is perhaps the case, or you could use the "netstat" Windows utility to verify whether vPilot was able to listen on UDP port 3290 or if it resorted to some other port instead.

Link to comment
Share on other sites

#2 is certainly possible if for some reason it thinks that port is in use or otherwise unavailable, in which case it'll allow a random, high-numbered port to be used instead.

 

Are you sure? I thought 3290 was hard coded into the VATSIM voice library. I didn't write it, so I could be wrong, but I thought that was the reason why you could never have more than one VATSIM client running at the same time, both using voice. VRC won't even start up if it can't open 3290. My other clients will still run, but voice won't work if 3290 is taken by another app.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Using this voice server (LiveATC - a common one), look at all of the pilot connections that aren't using port 3290. Here's an example:

 

user 2 name = "DFW_GND (1293257)", address = xxx.xxx.xxx.xxx:3290
user 3 name = "DAL1318 (1325477)", address = xxx.xxx.xxx.xxx:34494
user 4 name = "N2461N (1390147)", address = xxx.xxx.xxx.xxx:3290
user 5 name = "DAL153 (1377280)(0)", address = xxx.xxx.xxx.xxx:3290
user 6 name = "AAL2290 (1374832)", address = xxx.xxx.xxx.xxx:3290

 

I don't know what client DAL1318 is using, but its currently receiving voice data on UDP port 34494. The client likely requested a random UDP port from the O/S.

 

EDIT: And here's even an example of an ATC client using an abnormal port number:

 

user 2 name = "MKJP_APP (1363093)", address = xxx.xxx.xxx.xxx:11864

 

I always [Mod - Happy Thoughts]umed it was within the VVL code that would first try to bind to a certain client port (3290 for VRC, 3291 for vATIS, etc.) and, if that fails, then try to re-bind the listening port after clearing the port number (allowing the O/S to [Mod - Happy Thoughts]ign one from its dynamic port range). Perhaps it's only certain clients that do this?

Link to comment
Share on other sites

So in fact that even tho mine is set up correctly it could be the other end user?

No. Unless everyone else on the frequency is losing transmissions at the same time, it's very unlikely that the problem isn't on your side of the connection.

 

Can you connect to the network right now? If so, connect somewhere with ATC, tune to an active controller, and let me know the controller name - I can check the voice server for you and verify that UDP port 3290 is indeed being used. If it is, then I'll be fresh out of ideas to try. Your issue is perfectly described by a UPnP port timeout issue on your router... something that a manual port forwarding rule should completely eliminate.

Link to comment
Share on other sites

Well, that at least confirms port 3290 is the one you'd want to forward:

 

user 10 name = "VHVAA (943459)", address = xxx.xxx.xxx.xxx:3290

 

So we're at the point where I'm fresh out of ideas. Not sure if Ross or anyone else has any suggestions.

 

You can try digging around your router's settings to see if it has a setting for "UPnP Port Timeout" and, if so, increasing that time. If you can set that fairly high, then you hopefully wouldn't run into this issue as often.

 

Otherwise... I guess just tap your PTT key every few minutes if you haven't been transmitting?

Link to comment
Share on other sites

update!

 

Still not 100% convinced what we have all done is working 100% it chose when it wants to fully work and when it doesn't. Over at Vatpac a few others are having similar issues and have port forwarding set up! I also hear a lot ATC trying to get to pilots and there is no contact until ATC message pilot to reply and then they become "active" again.

Kyle Wilford

VATPAC Member

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...