Jump to content

FLAi FSX and P3D Model Matching for VATSIM


Recommended Posts

Mark,

 

I haven't used P3Dv4 for some time, but I THINK there was a change to how you add to SimObjects.cfg...or, at least, you have to edit a different file. It's possible you're changing the wrong SimObjects.cfg file. However, I don't know which one you need to modify, as I haven't done that before. It should also be noted that doing it this way won't enable FLAi's Effects or Texture folder additions.

 

Since you're using P3Dv4, I would recommend you try the add-on.xml method. As far as I know, you can use that method even when the files are installed on a separate drive. As I recall, you go to Docomeents\Prepar3D v4 Add-Ons. In that directory, you'll likely find some other add-ons you can use as a template. You'll likely be able to copy the file syntax for the others, and just point the directory to your E:\ drive.

 

If that doesn't make any sense to you, it's because I don't have any flight simulator installed on my PC at the moment, so I can't give you better advice than that. Do you want to give it a try, and let us know how it goes? In the interim, I'll ask the people who know more than me to try to give you some better advice.

spacer.png

Evan Reiter
Boston Virtual ARTCC/ZBW Community Manager

 

Link to post
Share on other sites

Mark,

Is there a chance you may have other AI packages installed onto your computer? Or have you used any AI packages previously that could be causing a conflict? The failed to create aircraft message is very important as the first three letters in XXXXX let us know if it's actually FLAi or another package.

 

On my own personal setup, I have FLAi running on my "M" drive under M:\FLAi, and my P3D installed on my SSD under the regular "C" drive. When using the FLAi Operations Center, you can specify where you want FLAi installed. I created a folder called FLAi on my M drive, pointed the installer to that folder, then pressed update. Once FLAi is finished installing it will create the addon.xml for you under your Docomeents\P3D Add-ons folder. Although the Simobjects.cfg method will work, it's not recommended as everything you need is condensed into your home FLAi folder and connected to P3D using it's native SDK.

 

Now try this:

 

1. Navigate to your Docomeents\Prepar3D v4 Add-ons and ensure there is no folder called, "FLAi" or "BVAI" or "SPAI." If there are then delete these folders.

2. Navigate to your Docomeents\vPilot Files folder and ensure there is no folder called, "FLAi" or "BVAI" or "SPAI." If there are then delete these folders.

3. Delete your FLAi folder you created in your SimObjects folder.

4. Delete any FLAi effects or texture files you moved over to the P3D equivalent folders.

5. Adding a path called Default Airplanes in SimObjects\FLAi\SimObjects\Airplanes might cause a conflict as it does not follow P3Dv4 SDK for third party addons. This is why we use the addon.xml method. It's quick, easy, and very organized. Editing core P3D configuration files is a huge headache, and one I personally stay clear of. One typo, out of order entry, or in this case the lack of a correct path can cause errors. Delete this entry you've added and save.

6. Start P3D without any AI installed and fly around for a few minutes. Also start Vpilot and ensure there are no AI packages listed in the settings\Model Matching\Advanced tab. The only thing that should be listed is SimObjects\Airplanes.

7. Download the FLAi Operations Center and Run As Administrator. If your computer doesn't give you the option to run it as administrator then that's fine.

8. Create a folder called, "FLAi" on your E drive. You can also use the default Appdata path if you wish to not create any new folders.

9. Go into the FLAi settings tab (Gear box icon) and change the simulator to P3Dv4 regular or with dynamic lighting. This is your choice, but if you use dynamic lighting in the simulator then go with the Dynamic Lights option.

10. Change the FLAi path to the folder you have created in the E drive. Ensure that after you press "OK" the path is correct. If you choose to use the default path, you can just leave it as Appdata.

11. Press Save, then update and let the installer do its thing.

12. Once the installer has finished, open P3D and enable FLAi when prompted. Please advise if you aren't prompted.

13. Load up at an airport with traffic, and open Vpilot. It may run through a self check to detect any new models. You should notice if you go into the Vpilot settings\Model Matching that there are now 1,800 or so models identified. You should also notice under Model Matching\Advanced that FLAI is listed and checked. FLAI should be the only model matching package listed. If there are others please uncheck them as they can conflict.

14. Under Vpilot Settings, click Model Matching\Custom Rules, and add the FLAi Model Matching.vmr. This is located in Docomeents\Vpilot Files. If there are other VMR files listed please delete these. Press Apply when finished.

 

Let us know if this fixes it. Although you can use the Simobjects.cfg method, FLAi was not designed to be used this way. An organized sim is a happy sim.

stb_beta.jpg

 

 

 

Untitled-1.jpg

My Traffic Version 5.2B Repainter and Beta tester!

Visit us at: www.mytraffic2004.com

Link to post
Share on other sites

Hi Matthew,

 

Thanks for your quick response.

 

The operations center did not give me an option to run as administrator, the only option was to open. I chose the default path in AppData to hopefully make things easier.

 

When I opened up P3D after the re-install there was no prompt to enable FLAi.

 

When opening vPilot it did not search for new aircraft and there is no FLAi model matching option, only the default.

 

All other steps were completed and I removed the entry I made into the SimObjects.cfg.

 

Thanks, I really do appreciate the help.

Mark

Link to post
Share on other sites

Hi Matthew and Evan,

 

I've been reading about the XML way to manage addons. I've noticed that on my system FLAi did not create a folder with a .xml file in the Docomeents\P3dv4 Addons folder. I created a folder and the .xml looks like this:

 

FLAi

FLAi

SimObjects

C:\Users\Mark\AppData\Roaming\FLAI

 

When starting P3D I had a prompt asking me to enable FLAi which I clicked yes. vPilot scanned due to thinking there were new aircraft, and there was an FLAi model matching option which is ticked. However, there are no models to been found.

 

Thanks,

Mark

Link to post
Share on other sites

Mark,

Change the addon.xml to the following:

 

FLAI

FLAI - Next Generation Model Matching

SimObjects

C:\Users\Mark\AppData\Roaming\FLAI\SimObjects\Airplanes

Effects

C:\Users\Mark\AppData\Roaming\FLAI\Effects

Texture

C:\Users\Mark\AppData\Roaming\FLAI\Texture

 

That should fix it.

stb_beta.jpg

 

 

 

Untitled-1.jpg

My Traffic Version 5.2B Repainter and Beta tester!

Visit us at: www.mytraffic2004.com

Link to post
Share on other sites
  • Board of Governors
Matthew I love you and want to have your babies. Thank you so much.

 

Congratulations! You've just won the Best Reply Of The Month Award!

 

Unfortunately, there's already quite a line of guys trying to have Matthew's babies... I'm afraid you'll have to wait your turn....

Don Desfosse
Vice President, Membership

Link to post
Share on other sites
Matthew I love you and want to have your babies. Thank you so much.

 

Congratulations! You've just won the Best Reply Of The Month Award!

 

Unfortunately, there's already quite a line of guys trying to have Matthew's babies... I'm afraid you'll have to wait your turn....

Oh, Don, is THAT why you've been pursuing.... nevermind, I probably can't say that here.

spacer.png

Evan Reiter
Boston Virtual ARTCC/ZBW Community Manager

 

Link to post
Share on other sites

Great package guys and thanks for putting it all together for the community. Is there a way to test all the models in P3Dv4 because I've noticed some are showing up as black aircraft?

 

I'll take notes as I see them but the one I do have was on the ground at EGKK and was a B772 with the callsign AUI37_

This was when using PSXSeeconTraffic. Due to the aircraft being parked at the gate I couldn't get the model info.

 

Thanks,

Danny.

Link to post
Share on other sites
  • 2 weeks later...
I installed FLAi and it did not install the model matching rule set for vpilot as far as I can tell. I read that it automatically puts the file into vpilot and you need to add it to the custom list. Can't find the file.

 

FLAi will place a ruleset on your computer, but you need to go into vPilot's settings and add it in. If you don't take this step, then you won't have the same detailed model matching you should. The file should be under Docomeents\vPilot Files, and you can add it in vPilot's settings: setup_configuringvpilot_4.png

spacer.png

Evan Reiter
Boston Virtual ARTCC/ZBW Community Manager

 

Link to post
Share on other sites
  • 1 month later...

Hello Eddy,

 

Anything you do to configure model matching on your computer will only affect how you see other aircraft. It will have no effect on how others see you. The only thing you can do to control how others see you is to use the correct type code for the Lancair Legacy when connecting to the network. Other users must have their model matching set up right to be able to show you as a Legacy. If they don't, they show you as their default model, which is often an Airbus or CRJ.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
Ross, update, I flyed the Lancair Legacy but used the C182 model to connect and the result is OOALE SMALL online !!!

Eddy, if you are flying the Lancair Legacy, you should connect as a LEG2. Even if that does not show up on a list, that is the correct identifier to have you properly appear for other users. If you connect as a C182 and are actually in a LEG2, your performance characteristics may be substantial in certain situations and controllers may misidentify you.

Link to post
Share on other sites
  • 7 months later...
  • Board of Governors

Alaqmaar, I suggest you provide A LOT more information to help folks help YOU troubleshoot. For example, which sim are you using, what didn't work, what did you try for troubleshooting steps, etc.

Don Desfosse
Vice President, Membership

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...