Jump to content

ERROR connect SquawkBox module on FS9

Recommended Posts

Hi Francisco,


last year all VATSIM-servers have changed IPs and so did the data-files. Squawkbox is trying to get the data from the URLs known to it, but it is timing out and it's causing a fatal error.


I invite you to join us at swift to enable you flying with FS9 and VATSIM. We have a number of pilots who are using swift already in connection with FS9, including me.





Make sure you download the 32bit-version as FS9 is a 32bit-program.


To help you getting started, have a look at our tutorial videos:


We will happily support you here or join us on our Discord server: https://dev.swift-project.org/w/contact/

Link to comment
Share on other sites

It may be that you do not have access at the moment until the servers have finished updating or have the SB been permanently terminated?

How would the configuration be through Regedit could you help me or tell me who I can contact to solve it.

From already thank you very much!!!!!

Link to comment
Share on other sites

Inside the windows registry the key would be HKEY_CURRENT_USER \ Software \ Level 27 Technologies \ SquawkBox \ 3 \ Networks \ VATSIM

I don't know if it is possible to add a new registry key with the new server. Would it be possible to do that ??? Could you help me???

Thank you

Link to comment
Share on other sites

It looks like this is the entry of Squawkbox, but I have never tried this. Have you Googled for this, maybe you'll find something.


I got to the same Registry entry as you, let me check if SB works with new IPs...


EDIT: I just tried running SB4, but it just disappeared after a few seconds, when fetching server information. Sorry, not good.


EDIT2: you could try to update a few of the servers from the current list, maybe it will help?

AFVDATA: :Toronto, Canada:AFV Beta Test:1:
GERMANY-1:, Germany:GERMANY-1:1:
SYD-1:, Australia:SYD-1:1:
UK-1:, UK:UK-1:1:
USA-WEST: Francisco, USA:USA-WEST:1:

Link to comment
Share on other sites

Hello, make the registry entry changes (REGEDIT) with the new entries:


[HKEY_CURRENT_USER\Software\Level 27 Technologies\SquawkBox\3\Networks\VATSIM]


"Description0"="Toronto, Canada"



"Description1"="Frankfurt, Germany"






"Description3"="Sydney, Australia"



"Description4"="London, UK"



"Description5"="New York, USA"



"Description6"="San Francisco, USA"




The problem is not that since I was working well until 3 days ago because the program started correctly and then in the IPserver unier field or I could put the address of any IP of the new servers and it worked perfectly.

The problem happened after the last changes in VATSIM. I enclose a screen of what happens:


The program simply does not start waiting for the message "Fetching Server Info: Loading network into for VATSIM"


Please help me over 20 years flying online on the vatsim network .... flying offline is very boring

Link to comment
Share on other sites

Francisco, do you happen to have another computer with Windows 7 or newer?


It should be possible to run swift on this second computer and connect to Windows XP/FS9 through FSUIPC+WideFS!




The main thing is that you'll need access to your model directory (shared drive).

Link to comment
Share on other sites

If it would be the option but it is too comebersome to re-install my entire simulator with the millions of modifications that I have made both on my PC and in the simulator itself .... after so many years I got the almost perfect configuration and it is a shame that I should Re install everything for this simple inconvenience. The Sb was a simple simple program that fulfilled its function as soon as the rest will be more beautiful complete the function is the same.

Within C: \ Program Files (x86) \ SquawkBox \ networks is an VATSIM.dll files, is there any possibility of getting this file modified or adapted with the new VATSIM configuration ???

When not initial the model imagined that the problem must come from that side ...

Thank you sorry for the absence but the truth is to install all my windows simulator etc etc would not be my option.

Link to comment
Share on other sites

Very nice! I am very happy for you that you were able to solve this problem.


Nevertheless I would like to ask you to maybe help us at the swift team. Do you have a second computer (can be anything, a notebook whatever) that has a 64bit windows operating system (Win 7 or newer) and run swift on it, then try to connect to FS2004 through WideFS. It would be interesting to see if it works.


EDIT: I just tested your fix and it has worked for me as well. There's just one draw-back: you will not get any voice with this solution, which is a big letdown. Should you be able to get swift to work on a second computer and connect it to FS2004, you'll be able to use voice.

Link to comment
Share on other sites

  • Board of Governors

Andreas, not to take anything away from the need to further develop swift, but for my own learning, is the lack of SB voice because of the missing .dll? Can't voice be used through AFV standalone?

Don Desfosse
Vice President, Membership

Link to comment
Share on other sites

Hi Don,


I have no idea whether "vatsim.dll" contains the old voice libraries, it might be the case and with all voice servers shutdown now, SB might hang up during start up. Removing it, solves the problem. But in any case AFV won't run on Windows XP and Francisco is not the only user with this configuration in VATSIM and we are simply wondering if swift, running on a compatible machine, will connect to FS2004 on an outdated version of Windows. And swift will not run on less than Windows 7, too, like AFV.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...