Jump to content

ERROR connect SquawkBox module on FS9


Recommended Posts

I could fix it !!!!! You delete VATSIM.dll located in C: \ Program Files (x86) \ SquawkBox \ networks and the SB works perfectly

I hope it works for others if someone had this problem.

Thanks to all for the help !!!!!

 

Francisco, Great find:!: I, too, was having the same problem; but I have Win7 and FSX. Tried your fix and up and running again. Unfortunately, I had to fly a flight yesterday for a VA to maintain currency and did it offline -- man, that sucked. I've really gotten used to VATSIM.

 

Although, this is just a temp fix, since I'll probably be moving to vPilot once SB audio is completely retired -- a few months, if i remember correctly.

823869.png
Link to post
Share on other sites
  • Board of Governors

Cliff, for what it's worth, my suggestion is to go to vPilot now. It's similar enough, but is currently supported by the developer, has the ability to use correct equipment types, and is an easy transition. Go for it! After 3-5 flights (normal learning curve), you'll never look back!

Don Desfosse
Vice President, Membership

Link to post
Share on other sites
It may be worth investing into a newer computer and Windows 10. You can still continue using FS9 with it!

 

I realize many shall consider this as "Snakry" whatever that means. But there are many of us, mainly old people like myself, who cannot simply run out and buy a new system, nor wish to spend the time, to install FSX/XPlane/Etc, and then the added money for addons, and the time to learn exaclty how to setup and run such.

No offense, but I would dearly love to be flying XPlane 11 right now. But as I said, I dont have spare cash to do so.

Please understand the underlying issue is that VATSIM has made changes, and for the "FEW" remaining FS9 pilots, it has caused issues with connecting. And sad to say it, but SWIFT is kind of all over the place and one has to go thru a lot to use it. I tried to set it up, all those AI files to download and add, and then going here and there to collect all that is needed and a poorly executed method of describing its set up. SB might be old and outdated, and I realize FS9 is the same.

Link to post
Share on other sites

Sad to say, but I made the changes described within the registry files for SB and it still does not connect, and now for some reason I select FS9 and a Rreg32.dll pops up and FS9 stops loading, I need to reselect FS9 again, and then close that DLL and the frozen FS9 stops and the simulator runs, but NOT Sqwaukbox. Removal of the VATSIM.DLL made no difference.

Link to post
Share on other sites

That's interesting that it does not work for you! So far, removing vatsim.dll has worked for everyone that I have talked to, including myself (I don't talk to myself thaaaaaat often, though )

 

Are you using Windows XP, too?

 

Re your reply about new hardware: yes, I am aware that not everyone can just stash out 1,500 USD for a new system like this and I do sympathize with you. At least with swift there's a future for members who prefer using FS9! I know that swift is a bit more complex than the other clients, but once you are done setting it up, you'll get the hang of it. Have you listened to my boring voice in our swift video tutorials already?

 

But first of all, let's try to get you going with Squawkbox.

Link to post
Share on other sites

I deleted Squakbox from my computer, I deleted all Registry files [Mod - Happy Thoughts]ociated with SB.

I have ran VIRUS, MALWARE, etc scans and I have a clean system.

I shall make one more attempt to reload Squakbox and all modifications that were in this thread.

If Squakbox refuses to connect after that, well, then that wil be the terminus for me with it and FS9.

After 13 years on VATSIM, the ability to fly connected is part of the lure of flying, without it, well, it will just be over. I personally cannot buy, and do not know how to build a new system. And as I said elsewhere, installing FSX or XPlane, buying addons so they look nice, and then the time to learn and get it all going nice. I am too old, I just no longer have enough time left for that sort of thing. Maybe 10 years ago, but not now.

I will repaet this, I connected and flew FS9 & Squakbox just fine on 2-29-2020, nothing was changed on my computer, yet when I attempted to continue my flight leg on 3-4-2020 I was met with the failure of SB to connect.

Link to post
Share on other sites

Hi Dennis,

 

don't give up

 

Yes, there was an upgrade/update of VATSIM's server software in the beginning of March and that's when SB stopped working the "old way". Removing vatsim.dll has resolved this issue for most (I though "all") members.

 

Are you using Windows XP? Or a more recent operating system? What are your computer specs? For X-Plane 11 you'll need a rather powerful machine, but the good news is that you will NOT need to buy a lot of costly addons, except if you care to buy the latest Airbus or whatever addon gets released. Just like in FS9 used to have, X-Plane 11 has a very active and generous user community that releases wonderful sceneries on a regular basis. There's also a really cool freeware Boeing 737-800 (ZiboMod) that comes along with almost all the bells and whistles like PMDG. I fly it all the time, I enjoy it and so do thousands of other X-Plane pilots.

 

We can try to schedule a direct support session to figure out what's wrong with your copy of Squawkbox! Do you use Discord? Skype? Teamviewer?

Link to post
Share on other sites

So I feel the need to add to this. I realize VASIM is seeking to improve itself and give its users a better Air Traffic Control System

I literaly spent many hours over many days attempting to get Squakbox to connect to VATSIM. It is NEVER a good thing to go digging in the registry files as once wrong move could mean a computer that becomes a paperweight. I performed all the suggestions and the end result is that Squakbox is now conceting to VATSIM, I have flown a flight online with ZERO problems.

However, despite the registry fix, I do not get a list. I had to manually input ( copy & paste) one IP address to connect. This is fine with me as it can be changed if needed.

Thanks to all who helped input solutions.

Link to post
Share on other sites

That's great news that you got SB to work according to our suggestions. I do not get a list as well, but that's something one can live with.

 

When the time comes to move over to swift, ask for help, we will gladly provide it.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...