Jump to content

Cannot transmit on vPilot


Recommended Posts

I have my mic calibrated and a PTT set up, when I tune into any frequency I can receive everything but I am unable to transmit. The TX box even lights up when I PTT but the controllers here nothing... any advice would be great! I am running P3D V4.4 and the latest version of vPilot which is in administrator mode along P3D.

Link to post
Share on other sites

If the TX indicator lights up and it recognizes your mic, I'm not sure what would be wrong. Are you sure you're transmitting on the right frequency (COM1 and not COM2)? Can you send a screenshot of the window?

Also, I moved your topic to the vPilot section, as that is the correct place to post. 🙂 Someone will probably respond soon!

Mats Edvin Aarø
General Manager - Member Engagement
Supervisor Team Lead: Team 4
[email protected]

VATSIM logo new

Link to post
Share on other sites

My problem is almost the same, my Vpilot recognises my voice transmission only when I press my PTT button in Vpilot window. If I press my PTT button when I'm in the FSX window, i can't transmit nothing, I just hear the ATC and traffics. 

 

Someone has an answer for that?

Edited by Gabriel Neves
Link to post
Share on other sites

This sound like FSX is running in Administratormode and VPilot not. Then when an Window in Adminmode has Focus, only the other Programs who run in Adminmode will recognize that Keypress.

So the Solution would be to run VPilot also in Adminmode.

Regards André

eddk,lsas,vatgerfb,vatgercpt,worldflight,euroscope,vatoic,fsrealwx.jpg1178638.png
Link to post
Share on other sites
  • 8 months later...

Something is still amiss, then.  Setting both COM frequencies to the same channel, ensuring your radio stack (and vPilot) reflect that you are monitoring both COM1 and COM2, you should hear yourself when transmitting.  Of course it's easy to say, "hey, it worked, why question it" but it might be worth additional investigation to prevent future frustration. 

Cheers,

-R.

fvJfs7z.png

Link to post
Share on other sites
  • 2 months later...

I had same issue noted above (multi devices working in Windows, in FS 2020 could hear live, but could not transmit, although TX button did illuminate).  Bob Klemm had the answer that worked for me - although took me a few to figure out that he meant "Anti Virus" when saying AV LOL).  I went into my Firewall settings, added VPilot to my "allow" list, and immediately started working.

Link to post
Share on other sites

Turns out it works ONLY when the V-Pilot window is open. When it's minimized, no one can hear you.  That's why it was working one time, and not another. Is there a fix for that.  And this is using P3Dv5

 

Bob Klemm

Link to post
Share on other sites
  • Board of Governors

@Bob KlemmBob, I've ever only heard that issue when either the sim or vPilot was *not* being run as Admin.  I know you said they both were, but can you double check that?

Don Desfosse
Vice President, Membership

Link to post
Share on other sites

Cant transmit or receive on any frwquencies on vpilot with new Aerosoft CRJ700/550ER.  Can change freqencies, press ident but nothing can be heard/ spoken.  Every other plane I have works fine on vpilot.    I have latest version 2.8.1 and tried as administrator - nothing.  

Edited by Darron Hedge
Link to post
Share on other sites

A lot of payware aircraft have transmitter and receiver selection functionality that most pilot clients respond to. To put it a different way, are you sure that you have a transmitter selected in the aircraft itself? Usually somewhere on the center pedestal there should be a small audio selection panel where you would select where the aircraft mic is to be routed: COM 1, COM 2, PA, etc. Make sure you have either COM 1 or 2 selected.

Link to post
Share on other sites
  • 2 weeks later...

Started doing it again. No one can hear my transmission. Running as administrator every time. It was working fine until yesterday. Same aircraft, etc. Comms 1 and 2 are selected. Works with Swift, but not Vpilot. PMDG 747, 777, QW 787 and CS 757.

 

Bob Klemm

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...