Jump to content

Another "Unhandled Exception" but different...?

Go to solution Solved by James Morgan,

Recommended Posts

Hey guys, sorry to clutter up the forum with this, but the solution that seems common to my issue doesn't appear to work for me - I start vPilot (both admin/normal), get error box "Unhandled exception has occured in your application..." that ends with "WaveBadFormat calling waveInOpen." From what I've gathered, it's usually a microphone permissions issue, but... I've looked in every nook and cranny I could find in Windows 10, and microphone permissions are definitely allowed.


One caveat maybe is I am using a digital interface that handles both the audio and microphone - all the settings in the vPilot show the DI, and is selected for both... but there's just no microphone audio when I go to the test page of vPilot.

Here's the beginning of the "details" part of the error box - please let me know if there's anything else I can provide.


************** Exception Text **************
NAudio.MmException: WaveBadFormat calling waveInOpen
   at NAudio.Wave.WaveInEvent.OpenWaveInDevice()
   at NAudio.Wave.WaveInEvent.StartRecording()
   at GeoVR.Client.Input.Start(String inputDevice)
   at GeoVR.Client.UserClient.Start(String inputAudioDevice, String outputAudioDevice, List`1 transceiverIDs)
   at e6.h()
   at e6.a(Object A_0, es A_1)

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 4.8.4250.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Users/JM/AppData/Local/vPilot/vPilot.exe


Thank you so much guys, sorry to bother you.



Link to post
Share on other sites
22 minutes ago, Nestor Perez said:

What do the "Advanced Options" of your device(s) look like?

Hey Nestor, it uses no external software - it plugs in USB, and is controlled by Windows like a normal sound card would be through default Win10 controls. All of those settings/drivers/levels are where they should be, and there are no issues with anything else. There's also no Advanced Options in Device Manager - it just contains general "This device is working properly" information with no options. Thanks for your time.

Link to post
Share on other sites
  • Solution

Just an update for any future somebody who happens to experience this same error message - got it working, I re-installed the Window's version of my Digital Interface's drivers (Focusrite). Don't be dumb like me, update your drivers even if they show up to date! Thanks @Nestor Perez

  • Like 1
Link to post
Share on other sites

Please excuse I naiveté , I am not a Wdo 10 expert, when  you say "update your drivers" ,which drivers do you mean.  WDOS is much  more complex regarding drivers than the MAC's with which I am more familiar.  I experience the error after upgrading the vPliot software to the current version.  It has disabled vPilot in my setup.  Any help you can provide is greatly appreciated . 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...