Jump to content

"Authentication Failed: A task was canceled" upon connection attempt


Jeff Callender
 Share

Recommended Posts

I am not a computer expert at all, but I am able to follow a set of instructions. I too am getting this problem.

To check my ipv6 connectivity I ran a test: went to https://ipv6-test.com/ and simply ran the test that opens - it also tested ipv4 connectivity.

When I did this my Ipv6 connectivity shows message "Not supported", which is actually wrong - it is supported (see below), as I have been able to connect to Vpilot (which apparently uses ipv6 to authenticate) correctly in the past. My student also gets "IPv6 not supported" when he runs this test - but he CAN connect to VPilot without a problem.

I have tried resetting my router several times, rebooting my computer as well. All without success.

When I go to  Control Panel>Network>Network and Sharing Centre> and click on my working internet network, it opens a window <Wi-Fi Status>. That page shows IPv6 Connectivity as "No Network Access".  If I then click <Details> the next window shows 3 IPv6 addresses: a main IPV6 address, a Temporary IPv6 address, and the usual internal  Link-local IPv6 address. What is missing is the 'IPv6 Default Gateway' and the 'IPv6 DNS server'.
If I then close that window (going back one step) and click on <Properties>, in the table I scroll down and come to <Internet Protocol Version 6 (TCP/IPv6)> which has the box at left ticked, so I assume this means it is installed.
In other words my system appears to have IPV6 installed and 'knows' it is there. It is 'just' prevented from using it.

This is the first time I have had this problem in 12 years plus of using VPilot. Any help would be much appreciated.

rr

Edited by John Pettit

Computer Spec:

Intel i9900K Super @ 3.60 GHz, nVidia RTX 2080i (11 GB DDR6 RAM onboard),

32 GB DDR4 RAM, 2TB HDD, 1TB SSD, 500 GB SSD, ASUSTek Z390-Plus Mobo

(LGA1151)

Scenery & Progs: Orbx Global & Vector & airports; UK2000 eXtreme

airports; PreparDv4.5; Aerosoft A32x Pro; vPilot; AS for P3Dv4;

Link to comment
Share on other sites

2 hours ago, John Pettit said:

When I did this my Ipv6 connectivity shows message "Not supported", which is actually wrong - it is supported (see below), as I have been able to connect to Vpilot (which apparently uses ipv6 to authenticate) correctly in the past.

Just because you have IPv6 enabled in your network settings, does not mean it's going to work. And having been able to connect with vPilot in the past does not mean you have IPv6, as vPilot can use either v4 or v6. This problem occurs when your system supports looking up v6 DNS addresses for the VATSIM authentication server, but then cannot actually reach those v6 IP addresses.

For now, try disabling v6 in your network settings. (Uncheck the box you referred to.) This won't uninstall IPv6, it'll just disable it for that network interface. This should prevent your system from looking up v6 DNS addresses, meaning it will only look up v4 addresses, and then vPilot should be able to connect to the VATSIM auth server on those v4 IPs. Report back here with the results.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Hi Ross,

You were beaten to the punch by Simon K  😂

He suggested the same thing at 18:46 this evening. Of course, it worked, just as you knew it would. Am now a very happy bunny!

It's the first time I have ever had a problem with VPilot, so that says something about the program reliability. Keep up the great work and don't let anyone get you down  😉

rr

Computer Spec:

Intel i9900K Super @ 3.60 GHz, nVidia RTX 2080i (11 GB DDR6 RAM onboard),

32 GB DDR4 RAM, 2TB HDD, 1TB SSD, 500 GB SSD, ASUSTek Z390-Plus Mobo

(LGA1151)

Scenery & Progs: Orbx Global & Vector & airports; UK2000 eXtreme

airports; PreparDv4.5; Aerosoft A32x Pro; vPilot; AS for P3Dv4;

Link to comment
Share on other sites

Note that I don't consider disabling IPv6 a good long-term solution, since it means your computer can't use IPv6 for anything at all. That's not a big deal right now, as most things that you'll connect to support IPv4 still, but that won't always be the case.

In an earlier post in this thread, I mentioned that I have a version of vPilot that will only use IPv4 when it connects to the VATSIM authentication server, and invited people to contact me on Discord if they are willing to test it out. Here's a link to that post:

 

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

I decided to go ahead and release the version of vPilot which uses only IPv4 addresses to connect to the VATSIM auth servers, as it has been working fine for me and a couple other testers.

@John Pettit Can you please re-enable IPv6 and then update to vPilot 3.4.7 (just released) and ensure that you can connect?

Same with anyone else having this issue. Please report back here with your results.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Good Morning Ross,

As requested, I have re-enabled IPv6 and upgraded vPilot to version 3.4.7.  I am happy to confirm that I have now been able to fully re-connect to vPilot!  😃
I did have to position to Arlanda in Sweden to find an ATC position open at this early hour so that I could check full functionality!

John

Computer Spec:

Intel i9900K Super @ 3.60 GHz, nVidia RTX 2080i (11 GB DDR6 RAM onboard),

32 GB DDR4 RAM, 2TB HDD, 1TB SSD, 500 GB SSD, ASUSTek Z390-Plus Mobo

(LGA1151)

Scenery & Progs: Orbx Global & Vector & airports; UK2000 eXtreme

airports; PreparDv4.5; Aerosoft A32x Pro; vPilot; AS for P3Dv4;

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...