Jump to content

vPilot 2.0 Open Beta now available


Ross Carlson
 Share

Recommended Posts

I'm looking for some brave souls to try out the vPilot 2.0 beta version. I say "brave" because nobody aside from myself has run version 2.0 yet, and it incorporates some major changes. You can expect that there will be bugs, probably show-stopping bugs that will make it unusable until I have a chance to fix them. Such is the case with untested software.

 

That being said, I would very much appreciate the help from anyone willing to give it a try and report your feedback.

 

Please make a backup of your existing installation in case you need to revert back to it. The existing installation can be found here:

 

%LOCALAPPDATA%\vPilot

 

The 2.0 installer lets you change the installation folder, so you can always put it in a different spot if you don't want to overwrite your existing 1.0 installation. However, I would prefer that you let it overwrite your existing installation in order to test that it properly upgrades your existing configuration file the first time you run version 2.0.

 

Here are the docs for version 2.0:

 

http://vpilot.metacraft.com/Docomeentation2.aspx

 

Here's a description of the major changes with some anticipated FAQs:

 

http://vpilot.metacraft.com/UpgradingV1toV2.aspx

 

Finally, here's the link to download the version 2.0 open beta installer:

 

http://vpilot.metacraft.com/DownloadHandler.ashx?m=0&ver=2.0.11&file=vPilot-Setup-2.0.11.exe

 

Please create a new thread here in the vPilot forum if you run into any issues.

 

Thanks for the help!

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

  • Replies 149
  • Created
  • Last Reply

Top Posters In This Topic

It won't make use of the PMDG models because they aren't part of the model database, and it can't determine the aircraft type and airline code by parsing the aircraft.cfg data.

 

The same may not be true of other complex add-ons, though.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Hi Ross.

 

Thanks for the new version.

 

Some issues here:

 

1. Cant't start in debug mode. Shortcuts p[Mod - Happy Thoughts] an invalid command line argument... "-mmlog". If I delete it, debug mode works as expected. This one is easy to fix...

 

2) Networked configuration. Set IP on remote computer... default port 8809 on both sides... Start host first then remote app... then remote app hangs with message:

 

Unhandled exception: value can't be null.

Parameter name: key

 

or something like that... It's in Portuguese, since my windows is also in Portuguese.

 

On the host side, I have the following log:

 

[11:35:24.001] vPilot version 2.0.0.0

[11:35:25.381] Simulator connection failed.

[11:35:27.960] Attempting simulator connection...

[11:35:30.380] Simulator connection failed.

[11:35:32.962] Attempting simulator connection...

[11:35:35.378] Simulator connection failed.

[11:35:36.849] Remote connected: 192.168.0.21:49722

[11:35:36.879] Remote disconnected.

[11:35:37.962] Attempting simulator connection...

[11:35:40.382] Simulator connection failed.

 

Just for the record... my FSX was not running yet (and it didn't matter, actually).

 

As you can notice, port number is different from the one I set on both applications and each time I run vPilot, I get a error log message with a different port number.

 

I tried to set Firewall off, too. No success.

 

Let me know if you need more information.

 

Marcelo Duran.

______________

Marcelo Duran

VATBRZ C1 - P2

VATSIM Supervisor

Link to comment
Share on other sites

Hi sir,

 

Nice to see always alive spirits, thx for the new version sounds good really.

 

Unfortunately i have a problem with model matching, check the picture below.

 

 

Untitled.png

Ismail El Moussati
Northern Africa Division Founder l VATSIM Network Supervisor
Royal Air Maroc Virtual CEO
Virtual AirTraffic Simulation Network

0.png

Link to comment
Share on other sites

  • Board of Governors

Lots of freeware and payware alternatives, though none as comprehensive and convenient as what I'm told the IVAO library is. WOAI is probably the most popular and comprehensive freeware source. I still pray that someday VATSIM will take on the project of developing its own library similar to IVAO's. Will be a huge undertaking, but so worth it!

Don Desfosse
Vice President, Membership

Link to comment
Share on other sites

Sir I have few problems while using VPilot 2.0.

 

 

* I need to have VPilot as my active software as in the VPilot should be in focus and selected to transmit voice. Without that the transmission does not occur.

 

*sometimes even while having VPilot in focus and pressing the PTT voice is not transmitted over.

 

*and if its suppose to display a 777 as a pmdg 777 if I own one. It isn't the case with me. I see a 777 as a Woai's 777.

 

Thank you. And all the best with the new version looks very very promising

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...